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WSS Introduction

Lecture Themes:

— Domain Interfaces are important features that connect dissimilar domains
or dissimilar meshes

— Many CFD applications across industries involve systems or devices with
moving parts. CFX offers many different models for rotating machinery,
for arbitrary prescribed motion and for objects whose motion is
determined by the flow.

Learning Objectives:

— You will be able to use domain interfaces and will become familiar with the
CFX models for systems with moving parts and when a particular model is
applicable.

Domain Interfaces > RotatingZones » Dynamic Mesh » Summary >
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WSSl Overview

. Where two 3D mesh regions meet :

— Two elements share one face (conformal) — no
interpolation necessary = 1:1 mesh interface

— Every element has its own face (non-conformal) —
interpolation of fluxes is necessary = Generalized
Grid Interface (GGI)

. Domain Interfaces are used for:
— Connection of unmatched meshes
— Changes in frames of reference

— Connect different types of domain, e.g. Fluid &
Solid

— Periodic regions within a domain

> Introduction _ Rotating Zone Dynamic Mesh > Summary >
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5

e Create a domain interface by right-clicking on ‘Flow
Analysis’ or use the toolbar icon i3

* 3 new objects in outline tree

— Interface object = edit to modify the domain interface

— Side 1 & Side 2 boundary condition = optionally specify
sources, set wall boundary conditions for non-overlap regions

Outline | Boundary: Default Fluid Porous Interface Side 1 | Domain: Default D¢ < |+ E3
Details of Default Fluid Porous Interface Side 1 in Default Domain in Flow Analysis 1

Basic Settings | Boundary Details | Nonoverlap Conditions | Sources

WSSl Domain Interfaces and Boundary Objects

Outlire
= g Mesh

+ Q] stator.gtm

+- [ rotor.grd

fﬁ Connectivity

= [ Simulation

= [ Flow Analysis 1

@ analysis Type

The Side 1 and Side 2

boundary conditions

% Ritosl Frozen Rotor Side 2 )
¥ P+ =TBlade

PE st Defaul

it stHwb

+ | Nonoverlap Conditions = jf 51 Inlet
Boundary Type |Wa” v| R1to 51 Frozen Rotor
Mass And Momentum B . leg Solver
Option |No Slip Wall | - Fits
Wall Velocity The Interface ObjeCt ftrol
nkral

2

Introduction _ RotatingZones » Dynamic Mesh » Summary »
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NSl Interface Models

Available Interface Models are:

* Translational Periodicity

— Allows for either the mass flow rate or the pressure
change across the interface to be specified

* Rotational Periodicity

®* General Connection

Interface Models

— For all other types of connections i Changemmg|§§§;@' Conicction ) .

— A Frame Change/Mixing Model and a Pitch Change can B [stage 7
be set where there are multiple frames of reference. Eﬁ:ustrfe:ﬂz.:;f?@nstramt
These are discussed in the Moving Zones section AT =

Option |Aut0matic v|

> Introduction _ RotatingZones » Dynamic Mesh » Summary »
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WS4 Additional Interface Models
Outline Domain Interface: Default Fluid Fluid Interface x|

Details of Default Fluid Fluid Interface in Flow Analysis 1

Basic Settings | Additional Interface Models | Mesh Connection

5 Mass And Momentum =]
. Represent source or sink of momentum, e.g. fan opton R
Q Q Interface Model =]
or porous wall, by speafymfg a pressur.e changeor "~ e o e .
a mass flow rate between side 1 and side 2 L I
Pressure Update N;
° When |nterface Model = General Connection Basic Settings | Additional Interface Models | Mesh Connection
Mass And Momentum =]
— Set up infinitEIy thin walls == Option [0 Slip wall =
. . i | . Wall Velocity .Conser\tative Interface Flux |
— Create a switch, using Conditional Connection oot Transter LAV
Control, to determine whether the interface is open Conditonal CoMECt sige pependent |
o Mass And Momentum =]
to flow or CIosedI l.e. a Wa" Option |C0nservative Interface Flux v|
» Define when interface is open or its state changes by ;ttrf Mode . | .
providing a logical expression, e.g. a function of time or :C e T——— =

pressu re dlfference Option llrreversible State Change v]

Logical Expression ESps_-ciﬁs_-d Open State

Initial State [Open -l

> Introduction _ RotatingZones » Dynamic Mesh » Summary »
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WS4 Mesh Connection Method

. 1:1
— Not available for Fluid-Porous and Porous-Porous
— Auvailable for Fluid-Fluid and Solid-Solid only within a single domain
— Not recommended for Fluid — Solid, Solid — Solid, Solid-Porous interfaces

c GGl

— If nodes on the 2 sides not aligned they should have similar edge lengths

— If the region for one side # the other, the connection will be between the
mutually overlapping surfaces

— use more memory and CPU than 1:1 connections

e  Automatic
— tries to make a 1:1 connection if possible, otherwise GGI
— GGI connection always used for Fluid-Solid, Solid-Solid and Solid-Porous

> Introduction _ RotatingZones » Dynamic Mesh » Summary »
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NSl Automatic Domain Interfaces

Dutline '*'[%
- iew
Fx '—1@ Import Mesh 3 v
* CFX-Pre automatically creates domain interfaces | 2% o Source Fie
. . . ) wansfarm Masl Region Type
within a single mesh assembly < @ oy Tensfom et =
— Connect multiple domains within the assembly Outline
- . = i@ Mesh
— Connect non-matching meshes within the assembly & @ CFX.cmdb
— Right-click on Mesh > View by > Region Type - ® Comnectivity
to see a list of assemblies in the mesh # (@] Flow Analysis 1
% Coordinate Frames
* Always check the automatic interfaces to make sure ] Materials
4] Reactions
they are Correct! + E Expressions, Functions and ¥ariables
= d] Simulation Control |

[m] Configurations

* Can disable automatic interface creation-> Case . @) Case Options
Options > General in the Outline tree © General

|:| Garaphics Style
gy Labels and Markers

* Create interfaces manually between mesh

> Introduction _ RotatingZones » Dynamic Mesh » Summary »
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WSS  Introduction

11

. Moving Frames of Reference
— Domain moves with coordinate system
— Equations are modified to account for moving frame
— Rotation or translation (translation in solids only)

— To follow the motion of the body, the topology of the
mesh does not need to be updated

. Mesh Motion /Mesh Deformation

— Domain position and shape are tracked with respect to
a stationary reference frame

— Solutions are unsteady or approach equilibrium

— Domain can change shape as a function of time,
topology of the mesh might need to be updated

_ Domain Interfaces > Rotating Zones )

Dynamic Mesh > Summary >
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NS <@ Rotating Equipment — Moving Frames of
Reference

* Why use a rotating frame of reference?

— Unsteady flow field when viewed in a stationary frame can become
steady when viewed in a rotating frame - easy to solve

— Additional acceleration terms are added to the momentum
equations

* Can employ rotational-periodic boundaries for efficiency

(reduced domain size)
| Centrifugal Compressor
* Limitation: (single blade passage)
— Existing unsteadiness in the rotating frame due to turbulence,
circumferentially non-uniform variations in flow, separation, etc.
* Example: vortex shedding from fan blade trailing edge

> Introduction » Domain Interfaces _ Dynamic Mesh > Summary >
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NSl Single vs. Multiple Frames of Reference

* Multiple Frames of Reference required if: SFR is sufficient:
— Stationary walls # surfaces of revolution

— Multiple rotating domains rotating

+ at different rates ol

* about different axes stationary wall

* Interface between rotating and
stationary zone must be a surface of
revolution with respect to the axis of
rotation

MPFR is necessary:
baffle

* Interfaces are always treated as GGls

stationary wall stationary wall
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Pitch Change

* Where there is rotational symmetry,
rotational periodicity reduces the size of
model, compared with full 360°

* Pitch change accounts for differences in
rotational symmetry between domains in an
MFR model

* Pitch Change is best set by

— Specified Pitch Angles = specify Pitch angle on
both sides

* The two sides do not need to line up
physically

14 © 2015 ANSYS, Inc. March 13, 2015 ANSYS Confidential



Steady State Modeling Approaches

 Single Reference Frame (SFR)

— Domain is referred to a single moving reference frame

*  Frozen Rotor (MFR)
— Fixed relative positions

— Fluxes scaled by pitch change = pitch change should be close to 1 for accuracy
— Transient Interaction effects are ignored

«  Stage (MFR)
— Circumferential averaging of fluxes in bands at the domain interface

— Incurs one-time mixing loss — suitable when relative motion at interface is large enough
to mix out any upstream velocity profile

— Accounts for time-averaged interaction effects

> Introduction ) Domain Interfaces _ Dynamic Mesh > Summary )
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WS Unsteady Modeling Approaches

Transient rotor-stator (MFR)
— Predicts true transient interactions between a stator and rotor passage
— Computationally expensive
— Pitch change should be exactly 1

 Transient Blade Row (TBR)

— Removes problem of unequal pitch - possible to model just one or two passages per
row rather than the full 360. Methods are:

* Profile Transformation
* Time Transformation
* Fourier Transformation

> Introduction » Domain Interfaces _ Dynamic Mesh > Summary >
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WSSl Interfaces

An intersection algorithm is used to find the overlapping parts of each
mesh face at the interface

. Interfaces that contain surfaces of both constant r and z have to be split.

Surface of

constant z

Surface of
constant radius
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ISl Mesh Deformation

* Mesh Deformation: moving boundaries or objects

* Nodal displacements are calculated, mesh adjusts to accommodate them

* Boundary / object motion can be moved based on:

— Specified displacement via Expressions

— Coupled motion: two-way Fluid Structure Interaction
— Sequential loading of pre-defined meshes

* Examples:
— Piston moving inside a cylinder
— Flap moving on an airplane wing
— Valve opening and closing

e Tutorials 22 & 23

AV AV

N

e,
xvi

A RV o
pAvAT s

> Introduction » Domain Interfaces

> Rotating Zones _ Summary >
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ISl Mesh Deformation

| Mesh Deformation

Cption Regions of Motion Specified
Details of X Displacement
° og_ o . . Definition Plok Evaluat
Describing Mesh Motion: e TIIE
== Basic Domain Settings . “Mesh Deformation" i 0.06 j .............................. .................................................
to “Regions of Motion Specified” 0, 004 -
. I T 00z 3
— Create expressions for nodal displacements or S
_ it - D o | ARSI SRR S , ...............................................
physical nodal locations ]
— Apply Mesh Motion equations at E_W (LIRS ............................................
boundaries/subdomains that are moving S e A O N S
0 2 4 & & 1w
Mesh Motion
Cption Specified Displacement w

Displacement

Opkion _artesian Components W
# Cornponenkt | ¥ Displacement |

¥ Companent 0 [m]

> Introduction » Domain Interfaces > Rotating Zones _ Summary >
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NWSHSE Summary

. Five approaches for moving zones
— Single (Rotating) Reference Frame Model (SFR)
— Multiple Frames of Reference (MFR)
* Frozen Rotor
* Stage
* Transient Rotor Stator
— Mesh Motion

SFR, Frozen Rotor and Stage methods are steady-state approaches;
Transient Rotor Stator is unsteady

All physical models are compatible with moving reference frames or
moving meshes (e.g. multiphase, combustion, etc.)

> Introduction » Domain Interfaces > RotatingZones »  Dynamic Mesh -
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Workshop

* Workshop 04 — Axial Fan Stage (MFR) ﬂ\

— Running ANSYS CFX outside ANSYS 1
Workbench | |

— Rotating domains

— Basic setup using multiple frames of
reference

— Turbo-specific post-processing < [

> Introduction ) Domain Interfaces > RotatingZones »  Dynamic Mesh -
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Porous Interface Usage

NANSYS

Domain interfaces involving porous domains are always treated as GGI

Total Pressure is unchanged across the interface
— Static pressure will show a discontinuity at the interface

Total Enthalpy (Total Energy) is unchanged across interface
— May see a discontinuity in Enthalpy (Temperature) in high speed flows

Total Pressure

!

Velocity

March 13, 2015 ANSYS Confidential
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WS4 Frozen Rotor Frame Change Model

. Frozen Rotor: Components have a fixed relative position, but the appropriate frame
transformation and pitch change is made

— Steady-state solution

[

Pitch change is
accounted for

rotation
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Frozen Rotor Frame Change Model

Frozen Rotor Usage:

— The quasi-steady approximation involved becomes small when the through flow speed is large
relative to the machine speed at the interface

— This frame change model requires the least amount of computational effort
— Transient effects at the frame change interface are not modeled

— Pitch ratio should be close to one to minimize scaling of profiles
* Adiscussion on pitch change will follow

Profile scaled down

Pitch ratio is ~2

26 © 2015 ANSYS, Inc. March 13, 2015 ANSYS Confidential



WS Stage Frame Change Model

e  Stage: Performs a circumferential averaging of the fluxes through bands on the
interface

— Accounts for time-averaged interactions, but not transient interactions

— Steady-state solution

) ui)stream

g,

Jow’]stream

g
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Stage Frame Change Model

. Stage Usage:

— Allows steady-state predictions to be obtained for multi-stage machines

— Incurs a one-time mixing loss equivalent to assuming that the physical mixing supplied by
the relative motion between components is sufficiently large to cause any upstream velocity
profile to mix out prior to entering the downstream machine component

— The Stage model requires more computational effort than the Frozen Rotor model to solve
but not as much as the Transient Rotor-Stator model

28 © 2015 ANSYS, Inc. March 13, 2015 ANSYS Confidential



WS4 Transient Rotor Stator Frame Change Model

29

. Transient Rotor-Stator:

— Predicts the true transient interaction of the flow between a stator and rotor passage

— The transient relative motion between the components on each side of the interface is
simulated

— The principle disadvantage of this method is that the computer resources required may be
large

— Initialise with converged solution from a Frozen Rotor or Stage model to minimise the
number of timesteps needed to establish the flow

© 2015 ANSYS, Inc. March 13, 2015 ANSYS Confidential



Pitch Change

 When the full 360° of rotating and stationary components are modeled the two sides
of the interface completely overlap

— However, often rotational periodicity is used to reduce the problem size

* Example: A rotating component has 113 blades and is connected to a downstream
stator containing 60 vanes

— Using rotationally periodicity, a single rotor and stator
blade could be modeled

— This would lead to pitch change at the interface
of (360/113): (360/60) = 0.53:1

— Alternatively two rotor blades could be modeled with
a single stator vane, as shown to the right, giving a
pitch ratio of 2*(360/113):(360/60) = 1.06:1

30 © 2015 ANSYS, Inc. March 13, 2015 ANSYS Confidential



31

WS  Setup Guidelines

Details of Inlet in R1 in Flow Analysis 1

Basic Settings Boundary Details Sources

Flot Options

< £

[

Boundary Conditions — are input quantities are relative to -

the Stationary frame, or the Rotating frame s
Walls which are tangential to the direction of rotation in

a rotating frame of reference can be set to be stationary

in the absolute frame of reference by assigning a Wall Lo J0 oo J{ con
Velocity which is counter-rotating i
Use the Alternate Rotation Model if the bulk of the flow Counter Roting ol

is axial (in the stationary frame) and would therefore
have a high relative velocity when considered in the
rotating frame

Cromain Motion
— E.g. the flow approaching a fan will be generally axial, with open R“a“”[gd :
Angular Yelocity: 523.6 [radian s™-1
little swirl

#lkernate Rotation Model

— Used to avoid “false swirl”

© 2015 ANSYS, Inc. March 13, 2015 ANSYS Confidential



WS Navier-Stokes Equations: Rotating Reference
Frames

Equations can be solved in absolute or rotating (relative) reference frame

* Relative Velocity Formulation

— Obtained by transforming the stationary frame N-S equations to a rotating reference
frame

— Uses the relative velocity as the dependent variable
— Default solution method when Domain Motion is ”Rotatiyg”

* Absolute Velocity Formulation

CFD domain

— Derived from the relative velocity formulation

— Uses the absolute velocity as the dependent variable rotating\ <

— Can be used by enabling “Alternate Rotation Model” frame \m
in CFX-Pre setup stationary @ A
7 frame X axis of
* Rotational source terms appear in momentum equations rotation

32 © 2015 ANSYS, Inc. March 13, 2015 ANSYS Confidential



WSS The Velocity Triangle

The relationship between the absolute and relative velocities is given by
V=W +U

In turbomachinery, this relationship can be illustrated using the laws of vector addition.
This is known as the Velocity Triangle

U =0 X7

V = Absolute Velocity

W = Relative Velocity

33 © 2015 ANSYS, Inc. March 13, 2015 ANSYS Confidential



WSS Comparison of Formulations

* Relative Velocity Formulation: x-momentum equation

ot OX

Coriolis acceleration  Centripetal acceleration

* Absolute Velocity Formulation: x-momentum equation

ot OX

Coriolis + Centripetal accelerations
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LWV Motion in Solid Domains

36

In most simulations it is not necessary to specify any motion in solid domains

Consider a rotating blade simulation in which the blade is included as a solid domain
and heat transfer is solved through the blade

* Even though the fluid domain is solved in a rotating frame of reference, the mesh is not actually
rotated in the solver. Therefore it will always line up with the solid

* The solid domain does not need to be placed in a rotating frame of reference since the heat
transfer solution has no Coriolis or centripetal terms

Solid domain motion should be used when the advection of energy needs to be
considered

* For example, a hot jet impinging on a rotating disk. To prevent a hot spot from forming, the
advection of energy in the solid needs to be included

© 2015 ANSYS, Inc. March 13, 2015 ANSYS Confidential



ANSYS Motion in Solid Domains

=0 x"
. Solid Domain Motion can be cIaSS|f|ed

into two areas: 4"=0 ////

— Translational Motion

* For example, a process where a solid
moves continuously in a linear direction
while cooling

* The solid must extend completely
through the domain

— Rotational Motion

* For example, a brake rotor which is
heated by brake pads

37 © 2015 ANSYS, Inc. March 13, 2015 ANSYS Confidential



LWV Motion in Solid Domains

In Solid Domains, the conservation of the energy equation can account for heat
transport due to motion of the solid, conduction and volumetric heat
sources

%’Oh)jLV-(,oUS )=V -(AVT)+ S

Solid Velocity

Note that the solid is never physically moved when using this approach, there is
only an additional advection term added to the energy equation

38 © 2015 ANSYS, Inc. March 13, 2015 ANSYS Confidential



WS Translating Solid Domains

Dekails of R1 in Flow Analysis 1

Basic Settings | Solid Models Initialisation Solver Contral

Enable Solid Motion fest Taneter .
Opkion Thermal Eneragy
Thermal Radiation =]
Optian Hone

Specify Solid Motion in terms of Cartesian -

Velocity Components oemd Carestan olocky Comporentz

U 0ms~-1]
Y a m 51 =
W 0.2 [m s™-1]
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WSS Rotating Solid Domains

Material Alurniniurn
- 0 . R Marphalogy
Rotating Solid Domains can be set up in one of option Continuous sold

two ways:

Domain Models

Dornain Makion

Option Stationary

* Solid Motion Method

Basic Settings | Soiid Models | Initislisation | Solver Control

— On Basic Settings tab, set the Domain Motion
to Stationary

Heat Transfer

Cption Thermal Energy
— On the Solid Models tab, set Solid Motion to Thermal Radiation
ROtati n g Option Horne
u i : B 5 S e STl R
The solid mesh does not phy5|cal.ly rotate, .but —
the model accounts for the rotational motion out .
ption Rokating
Of the SOIId energy Anagular Yelority 50 [radian s™-1]

Az Defimition

Option Coordinate Axis

Rokation Axis Global 2

all 3
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WSS Rotating Solid Domains

= ROtating Domain MethOd Material Alurniniurn w B
Morphology =
— Set the Domain Motion to “Rotating” Sa— Continuos Solid 3
— Do not set any Solid Motion
arnain Fodels
To account for rotational motion of solid energy or | ™"
Opkian R.okating W

a heat source which rotates with the solid, a
angular Yelogity

25 [radian 5™-1]

transient simulation is required and a Transient
Rotor Stator interface must be used

Note: “Solid Motion” as applied on the “Solid Models” tab is calculated relative to the
Domain Motion, so is not normally used if “Domain Motion” is “Rotating”
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